HLS_arbitrary_Precision_Types/packages/hls-ap-types-arch/PKGBUILD
2022-02-14 12:09:23 +01:00

22 lines
667 B
Bash

# Maintainer: DrasLorus <draslorus@draslorus.fr>
pkgname=hls-ap-types
pkgver=0.0.1.rc2
pkgrel=1
pkgdesc="AP types for everyone"
arch=('any')
url="https://github.com/DrasLorus/HLS_arbitrary_Precision_Types"
license=('Apache')
source=("https://github.com/DrasLorus/HLS_arbitrary_Precision_Types/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('90837e08801ab75f9084c6070a14ee60cae0d78b6a4bec47f1b49a4b9772b90d')
package() {
cd "$srcdir"
make PREFIX="${pkgdir}" install
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" "${pkgname}-${pkgver}/LICENSE.TXT"
}